We are not available by phone

Incident Report for Exxas

Resolved

The interruption with the communication provider has been resolved. We can be reached again by phone on the main number and direct numbers.
Posted Aug 16, 2024 - 13:27 CEST

Identified

The communication provider has identified the problem and is working to resolve it.
Posted Aug 16, 2024 - 09:18 CEST

Investigating

Our communication provider is experiencing a disruption. We are currently unavailable by phone on our main and direct numbers. Video conferencing and internal communication are still possible.
Posted Aug 16, 2024 - 09:14 CEST
This incident affected: Support and customer service.