The phone service disruption has been resolved by our provider.
Posted Mar 03, 2026 - 17:35 CET
Identified
We are currently unavailable by phone. Our telephone provider is experiencing infrastructure issues. Incoming and outgoing calls are not possible. The operation of the Exxas platform is not affected.
Posted Mar 03, 2026 - 17:12 CET
This incident affected: Support and customer service.